Pour résoudre l’erreur ‘from PyQt4 import QtGui’ lors de compilation de programme Python utilisant PyQt

Pour résoudre l’erreur  ‘from PyQt4 import QtGui’ lors de compilation de programme Python utilisant PyQt

 

Il faut installer Macport : https://www.macports.org/install.php

  1. cd” là ou le package est téléchargé et lancer“tar xjvf MacPorts-2.3.4.tar.bz2” ou “tar xzvf MacPorts-2.3.4.tar.gz”, dépendant du type d’archive téléchargée.
  2. Compiler et installer les source decompressée:
    • cd MacPorts-2.3.4
    • ./configure && make && sudo make install

    En option (pour supprimer les source):

    • cd ../
    • rm -rf MacPorts-2.3.4*

Et ajouter à Xcode : http://pythonschool.net/pyqt/distributing-your-application-on-mac-os-x/

  1. sudo port selfupdate – this updates MacPorts to the latest version
  2. sudo port install py33-pyqt4 – this installs Python 3.3 and PyQt4
  3. sudo port install py33-tkinter – this installs required libraries to run IDLE

Python et PyQt sont maintenant installé, Pour tester l’installation:

  1. Ouvrir Applications/MacPorts/Python3.3/IDLE
  2. Et dans un script Python:
    • from PyQt4.QtGui import *

Si il n’y a pas de message c’est gagné …

Leave a Comment